Strona 1 z 1

XU1541 (USB => 1541) - Instalacja

: śr kwie 07, 2010 11:55 pm
autor: prezes
[DRAFT]

Mysle ze taki watek jest potrzebny. Nie od dzis wiadomo ze instalacja XU1541 jest upierdliwa jak kamienie stolcowe w jelicie Warlocka. Plug&Play nie zadziała. Podlaczenie kabli do komputera + odpalenie GUI = failure. Verbosity softu - jakie verbosity?

To co napisałem zadzialalo u mnie na Windows XP. Linux (przynajmniej moje Ubuntu 9.10) to tylko pobożne życzenie z aukcji Rafa.

Kolejnosc wazna.

1. Sterownik

http://www.trikaliotis.net/Download/xu1541-drv.zip

Rozpakuj gdzies archiwum ze sterownikiem (xu1541-drv.zip) - powinno byc 5 plikow:
libusb0.dll
libusb0.sys
libusb0_x64.dll
libusb0_x64.sys
xu1541.inf

Podłącz pudełko z 1541 i wlacz stacje (dioda zasilania ma swiecic).
Potem podlacz pudelko kablem USB do PC. Jesli najpierw podlaczysz USB a potem stacje moze nie zadzialac.

Windows wyswietli kreator 'Znaleziono sprzet'. Wybierz opcje instalacja z wybranej lokalizacji i wskaz plik sterownika (xu1541.inf). Instalacja powinna przejsc bezproblemowo.

:idea: Uwaga! Sterownik jest wrazliwy na to do ktorego konkretnie portu jest podlaczony kabel. Windows chce instalowac urzadzenie od nowa przy podlaczeniu do innego portu.

Działający sterownik dodaje wpis w Menedzerze urządzeń (kiedy kabel jest podlaczony):

Obrazek
Obrazek
Obrazek
Obrazek

2. OpenCBM

http://www.trikaliotis.net/Download/opencbm-0.4.0.80/opencbm-0.4.0.80-i386.zip
http://www.trikaliotis.net/Download/opencbm-0.4.0.80/opencbm-0.4.0.80-amd64.zip

Rozpakuj archiwum z OpenCBM.

Zainstaluj - uruchom polecenie z konsoli (konsola = cmd.exe):

Kod: Zaznacz cały

instcbm xu1541


// TODO: log i c.d.

3. GUI - CBMXfer

http://www.6502.org/users/sjgray/software/cbmxfer/cbmxfer027b.zip

Zainstaluj DOT.NET Framework 2.0.

// TODO: url

Rozpakuj archiwum.

Uruchom CBMXfer.exe.

W okienku Options kliknij przycisk 'Detect Drive'. Prawda zostanie objawiona.

// TODO: komunikat

// TODO: screenshot

-----------------

// TODO: Tips & Tricks

Linki
- Strona projektu XU1541 http://www.trikaliotis.net/xu1541
- OpenCBM 0.4.2 Users Guide http://opencbm.trikaliotis.net/
- CBMXfer http://www.6502.org/users/sjgray/software/cbmxfer/cbmxfer.html
- GUI4CBM4WIN http://blog.paytonbyrd.com/?cat=11


Nie wiem ile są warte paczki instalacyjne Rafa bo dla zasady ich nie dotykalem ;)

Jesli sa lepsze pomysly na instalacje albo leżę w błędzie to piszcie pod spodem.

Prosze o usuwanie z watku gadki szmatki.

: czw kwie 08, 2010 12:03 pm
autor: skull
Hehe, no dobra teraz ja się wypłaczę...
Na początku od razu nadmienię, że rozwiązaniem "kabel XU" jestem zawiedziony - a mam również wersję Raf-a.

Mam obecnie na jednym z kompów Win XP pro MCE, i kabel działa niedostatecznie. Co to znaczy ? Wczytuje tylko katalogi, przenoszenie plików, kończy się fiaskiem, i zwieszaniem WIN4CBM/XFer. Muszę przyznać, że tu kabel Raf-a wygrywa, kopiuje - ale też na samym końcu ma problem z zakończeniem operacji - chociaz plik sie pojawia na dysku. Przedtem miałem innego xp i na tamtym kabel Raf-a działał bez zarzutów (szkoda, że wtedy nie miałem tego kabla).

Ale przytoczmy kilka faktów o XU (mówie tu o obydwu kablach):

1) Jeśli chcecie go zainstalować na Viście tudzież win7 to zapomnijcie, w żaden sposób nie udało mi się zmusić system do zainstalowania driverów - a wiąże się to z podpisaniem driverów certyfikatem - kombinowałem z różnymi programikami -> dupa, może ktoś mial wiecej szczęścia.

2) Transfer danych jest zajebiście powolny, kojarzy mi się z wgrywaniem z kasety bez turbo. Jedyny plus to formatowanie dyskietek idzie całkiem żwawo.

3) Myślałem że jak już się zainstaluje drivery to poprzez tak wolny transfer te rozwiązania są niezawodne, niestety okazuje się że nie (patrz początek posta).


Uważam, że kabel XE jest na dzień dzisiejszy lepszym rozwiązaniem - a kurw. muszę się i tak męczyć bo za każdym razem gdy chce coś przekopiować na real c64, zamykam windowsa, uruchamiam system (DOS) z dyskietki FDD, i kopiuje z pen drive : Uroki Systemu Vista,win7 oraz dysków SATA.

: czw kwie 08, 2010 2:44 pm
autor: jad
skull pisze:Mam obecnie na jednym z kompów Win XP pro MCE, i kabel działa niedostatecznie. Co to znaczy ? Wczytuje tylko katalogi, przenoszenie plików, kończy się fiaskiem, i zwieszaniem WIN4CBM/XFer. Muszę przyznać, że tu kabel Raf-a wygrywa, kopiuje - ale też na samym końcu ma problem z zakończeniem operacji - chociaz plik sie pojawia na dysku. Przedtem miałem innego xp i na tamtym kabel Raf-a działał bez zarzutów (szkoda, że wtedy nie miałem tego kabla).

rzeczywiscie. kopiowanie plikow nie dziala. ja sobie wczesniej przygotowywalem plik .d64 i calosc wrzucalem na dyskietke.
skull pisze:1) Jeśli chcecie go zainstalować na Viście tudzież win7 to zapomnijcie, w żaden sposób nie udało mi się zmusić system do zainstalowania driverów - a wiąże się to z podpisaniem driverów certyfikatem - kombinowałem z różnymi programikami -> dupa, może ktoś mial wiecej szczęścia.

instalowalem i uzywalem kabla pod vista. zero problemow z instalacja.

sprawdz zawartosc pliku 'c:\Windows\System32\opencbm.conf'.
u mnie wyglada tak:

Kod: Zaznacz cały

[xa1541]
location=C:\Windows\system32\opencbm-xa1541.dll

[xm1541]
location=c:/windows/system32/opencbm-xa1541.dll

[xu1541]
location=c:/windows/system32/opencbm-xu1541.dll

[plugins]
default=xu1541

: czw kwie 08, 2010 9:24 pm
autor: skull
jad pisze:instalowalem i uzywalem kabla pod vista. zero problemow z instalacja.


Mówisz o 64bit ?(bo zapomniałem dodać)

: ndz kwie 11, 2010 8:23 pm
autor: Raf
w zwiazku z prosba Kenjiego moj instatalaor po raz kolejny, tym razem na normalnym serwerze ;)

http://zsi.tech.us.edu.pl/~swi/inne/ope ... 0setup.rar

Linux (przynajmniej moje Ubuntu 9.10) to tylko pobożne życzenie z aukcji Rafa


DJ Gruby uruchomil na Linuxie.

: pn kwie 12, 2010 9:58 pm
autor: kenji
Udało mi się kabel odpalić. Wszystko chodzi tak jak powinno.

Miałem jeden problem podczas instalacji - stąd prośba do Rafa (dzięki za sterowniki) - nie wiem czy to jest reguła, czy czegoś nie doczytałem, ale OpenCBM dał się uruchomić tylko wtedy gdy był w katalogu głównym. Jak miałem go w katalogu ze znakami typu !_ i spacja, to nie było szans na komunikację ze stacją.

Korzystając z okazji: Prezes - dzięki!

: pt lip 30, 2010 11:13 am
autor: Nitro
Dziś doszedł do mnie kabel, z edycji społecznościowej.
Na Win 7 wszystko działa idealnie, nic dodać nic ująć.

: pt gru 24, 2010 3:25 am
autor: kenji
Niedawno musiałem przeinstalować Windows XP. No i niestety, po reinstalce nie ma mowy o uruchomieniu XU1541. Ciągle nie widzi napędu. Skończyły mi się już pomysły co robić dalej.

Na co powinienem zwrócić uwagę?

: pt gru 24, 2010 10:16 am
autor: DJ Gruby
Raf pisze:
Linux (przynajmniej moje Ubuntu 9.10) to tylko pobożne życzenie z aukcji Rafa.

DJ Gruby uruchomil na Linuxie.

Yup! Nie było żadnych większych problemów (Fedora)... Jeśli dobrze pamiętam, to chyba pod Windowsem właśnie miałem więcej kłopotów z uruchomieniem ustrojstwa. ;) Aha, nie testowałem jeszcze urządzenia Prezesa, tylko wersję zmontowaną własnoręcznie... :)

: czw sty 06, 2011 8:46 pm
autor: DJ Gruby
Piszę właśnie dość obszerny tutorial, jak zainstalować i uruchomić kabelek pod Linuxem. Mam nadzieję, że przyda się także tutaj.

Re: XU1541 (USB => 1541) - Instalacja

: wt maja 15, 2018 9:23 pm
autor: romeok01
Na moim blogu opisałem budowę i instalację XU1541 -> https://ccomodore64.blogspot.com/2018/05/budowa-xu1541.html